Ответить
  • Andrew-1978 Senior Member
    офлайн
    Andrew-1978 Senior Member

    18320

    14 лет на сайте
    пользователь #50772

    Профиль
    Написать сообщение

    18320
    # 3 июля 2017 11:55

    Energizer., ищите в модулях что то вроде Окр(Переменная, 0, 1) или Цел (Переменная), и это надо поменять на Окр(Переменная, 2, 1).

  • Energizer. Member
    офлайн
    Energizer. Member

    183

    11 лет на сайте
    пользователь #196656

    Профиль
    Написать сообщение

    183
    # 3 июля 2017 12:12 Редактировалось Energizer., 1 раз.

    Andrew-1978, уже пытался, не помогает =(

    ИначеЕсли (ИмяРеквизита = "Количество";) Тогда
    Сумма = ОКР((Цена*Количество),ОКРУГЛЕНИЕ,1);
    РассчитатьНалоги();
    Всего = глПоказательДокумента(Контекст, "СуммаСНалогами");
    ИначеЕсли (ИмяРеквизита = "Цена";) Тогда
    Сумма = ОКР((Цена*Количество),ОКРУГЛЕНИЕ,1);
    РассчитатьНалоги();

    Меняю во 2 и 6 строке слово округление на 2 и ничего не меняется

    есть еще в конце модуля процедура самого округления, может ее как-то изменить?

    Процедура Округление()
    Если ПустоеЗначение(ОкруглятьДо) = 1 Тогда
    Сообщить("Не задан способ округления");
    Возврат;
    КонецЕсли;

    ВыбратьСтроки();
    Пока ПолучитьСтроку() = 1 Цикл
    СпособОкргления = ОкруглятьДо;
    Округление = Число(СокрЛП(Строка(СпособОкргления)));
    п = Цена - Цел(Цена/Округление)*Округление;
    Если (п < Округление/2) Тогда
    Цена= Цел(Цена/Округление)*Округление;
    ИначеЕсли (Округление/2 <= п) и (п < (Округление/2+Округление)) Тогда
    Цена = Цел(Цена/Округление)*Округление + Округление;
    ИначеЕсли (п >= (Округление/2+Округление)) Тогда
    Цена = Цел(Цена/Округление)*Округление + Округление*2;
    КонецЕсли;
    Пересчет("Цена");
    КонецЦикла;
    КонецПроцедуры

  • Andrew-1978 Senior Member
    офлайн
    Andrew-1978 Senior Member

    18320

    14 лет на сайте
    пользователь #50772

    Профиль
    Написать сообщение

    18320
    # 3 июля 2017 12:23

    Energizer., у Вас проблема не в цене, ищите

    код выделить все
    НДС =
    Сумма =
    Всего =
    СуммаСНДС =
  • Energizer. Member
    офлайн
    Energizer. Member

    183

    11 лет на сайте
    пользователь #196656

    Профиль
    Написать сообщение

    183
    # 3 июля 2017 12:35

    Andrew-1978, Вы имеете ввиду это?

    Процедура РассчитатьНалоги()

    НДС = глПоказательДокумента(Контекст, "НДС");
    НП = глПоказательДокумента(Контекст, "НП");
    Всего = глПоказательДокумента(Контекст, "СуммаСНалогами");
    Форма.НДС.Видимость(глПризнакУчетаНалога(Контекст, "НДС"));
    //Форма.НП.Видимость(глПризнакУчетаНалога(Контекст, "НП"));

    КонецПроцедуры // РассчитатьНалоги()

  • Andrew-1978 Senior Member
    офлайн
    Andrew-1978 Senior Member

    18320

    14 лет на сайте
    пользователь #50772

    Профиль
    Написать сообщение

    18320
    # 3 июля 2017 12:44

    Кстати, а в самом документе тоже НДС и СУММА целые, или только в печатной форме?

  • Energizer. Member
    офлайн
    Energizer. Member

    183

    11 лет на сайте
    пользователь #196656

    Профиль
    Написать сообщение

    183
    # 3 июля 2017 12:48

    в документе тоже целые

  • Andrew-1978 Senior Member
    офлайн
    Andrew-1978 Senior Member

    18320

    14 лет на сайте
    пользователь #50772

    Профиль
    Написать сообщение

    18320
    # 3 июля 2017 12:58

    Energizer., тогда надо смотреть в глобальном модуле функцию

    код выделить все
    глПоказательДокумента
  • Energizer. Member
    офлайн
    Energizer. Member

    183

    11 лет на сайте
    пользователь #196656

    Профиль
    Написать сообщение

    183
    # 3 июля 2017 13:03

    Andrew-1978, Спасибо огромное! Два дня мучений не прошли даром благодаря Вам! :super: :beer:

  • Dama-modama Junior Member
    офлайн
    Dama-modama Junior Member

    45

    9 лет на сайте
    пользователь #411610

    Профиль
    Написать сообщение

    45
    # 17 июля 2017 16:58 Редактировалось Dama-modama, 1 раз.

    :rotate:

    [censored by Kilav.S п.п.3.3.4]
  • Keitlin Neophyte Poster
    офлайн
    Keitlin Neophyte Poster

    23

    9 лет на сайте
    пользователь #345227

    Профиль
    Написать сообщение

    23
    # 12 января 2018 15:18 Редактировалось Keitlin, 1 раз.

    Добрый день! У меня проблемка может кто помочь?! Работаю в новой базе с 01.07.16 деноминированной.
    Сегодня чтобы красиво по договорам все сходилось перепровела нечайно выписку от 22.04.16 и соответственно теперь я имею большое кол-во нулей в сч 60,62 и 51........а также 18 счета.....что мне сделать теперь?! Подскажите кто нибудь!!!!